Unable to start "/usr/bin/update-manager

View previous topic View next topic Go down

Unable to start "/usr/bin/update-manager

Post by figarow on Thu Oct 08, 2015 8:44 pm

I get the following error message when "Software Updater" is clicked

Unable to start "/usr/bin/update-manager"
Failed to execute child process "/usr/bin/update-manager" (No such file or directory)
avatar
figarow

Posts : 2
Join date : 2015-05-05

Back to top Go down

Re: Unable to start "/usr/bin/update-manager

Post by BroDan on Tue Oct 13, 2015 10:46 am

Hi figarow...your problem is beyond my knowledge. Are you able to update your system through the terminal by typing...

sudo apt-get update

I did find this article that might help. It sounds as though you might be missing some dependencies for some reason.

There are two answers given. Whether this will fix your problem, I'm not sure though. Sorry that I couldn't be more help.

https://askubuntu.com/questions/684043/software-updater-not-updating-and-sudo-apt-get-update-is-full-of-errors-ubuntu
avatar
BroDan

Posts : 85
Join date : 2015-05-07

Back to top Go down

Re: Unable to start "/usr/bin/update-manager

Post by figarow on Tue Oct 27, 2015 5:11 pm

sudo apt-get update worked ok.

sudo apt-get upgrade returns this..

BEGIN failed--compilation aborted at (eval 1) line 3.
) -- aborting
(Reading database ... 379949 files and directories currently installed.)
Preparing to unpack .../tzdata-java_2015g-0ubuntu0.14.04_all.deb ...
Unpacking tzdata-java (2015g-0ubuntu0.14.04) over (2015f-0ubuntu0.14.04) ...
Preparing to unpack .../tzdata_2015g-0ubuntu0.14.04_all.deb ...
Unpacking tzdata (2015g-0ubuntu0.14.04) over (2015f-0ubuntu0.14.04) ...
Setting up tzdata (2015g-0ubuntu0.14.04) ...
Can't locate POSIX.pm in @INC (you may need to install the POSIX module) (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/Template.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 8.
Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 10.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: error processing package tzdata (--configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
tzdata
E: Sub-process /usr/bin/dpkg returned an error code (1)
avatar
figarow

Posts : 2
Join date : 2015-05-05

Back to top Go down

Re: Unable to start "/usr/bin/update-manager

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum